Autor Wątek: KDE4 uber alles!  (Przeczytany 1534 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
KDE4 uber alles!
« dnia: Marzec 19, 2015, 13:02:25 »
Wprawdzie KDE4 idzie w zapomnienie (wraz z aplikacjami Qt4), jednakże wciąż jeszcze są osoby, które chcą używać tego środowiska i aplikacji dla niego stworzonych (czyt. opartych o Qt4 i biblioteki KDE4), podczas, gdy coraz więcej aplikacji pochodzących od KDE pojawia się już w wersjach opartych o Qt5 i KF5.
Dla wszystkich, którzy chcieliby swoje KDE4 utrzymać zatem jak najdłużej (ostateczna, sensowna data, to 31.12.2015 r., chyba, że Qt4 zostanie przez kogoś przejęte i nadal rozwijane), polecam następujące sposoby utrzymania aplikacji KDE4 przy życiu.
1. Dodanie repozytorium (jedynie 64 bitowe) kde4-masolit:
Do pliku /etc/pacman.conf dopisujemy:
[kde4-masolit]
SigLevel = Optional TrustAll
Server = http://masolit.me/kde4-masolit/$arch
W tym repozytorium są stare wersje paczek z KDE Applications (aktualnie wersja 4.14.3) oraz stare KDE Telepathy (wersja 0.9), jak również kilka innych programów, jak np. smplayer, które zbudowane są w oparciu o Qt4.
Uwaga: To "prywatne" repozytorium użytkownika "masolit", który - przynajmniej jak na razie - zrobił to dość mechanicznie, dodając tam KDE Applications w wersji 4.14.3, nie bacząc na to, że tak w pośród Applications 14.12, jak i pośród nadchodzących 15.04, jest sporo aplikacji opartych o Qt4 i biblioteki KDE4, które zawierają jakieś poprawki. Rozsądek nakazuje stosować je tylko i wyłącznie dla tych aplikacji KDE4, które w kolejnych wersjach KDE Applications są już w wersjach na Qt5/KF5. Tym samym np. część aplikacji z KDE Applications 14.12.3, osoba, która chciałaby je zachować w wersjach Qt4/KDE4, winna dodać do IgnorePkg w /etc/pacman.conf. W ten sam sposób należałoby postąpić w przypadku kolejnych wydań KDE Applications.

Druga metoda, to wykorzystać "system" ARM repozytorium seblu.net, gdzie gromadzone są migawki repozytoriów Archa i dokonać obniżenia wersji aplikacji już opartej o Qt5/KF5 do ostatniej wersji opartej o Qt4/KDE4, a następnie taką aplikację dodać do IgnorePkg.

Trzecia, to kompilacja z użyciem bądź to ABS, bądź to pojawiających się w AUR aplikacji, które używają jeszcze Qt4 (np. kdegraphics-gwenview-qt4). Oczywiście aplikacje takie będą aktualizowały się wraz z nadchodzącymi wydaniami KDE Applications. Kompilując, możemy się jednak posłużyć pewną sztuczką. Otóż możemy w PKGBUILDzie dodać (lub wykorzystać) pozycję groups i dodać w niej jakąś nazwę np. modified czy dowolną inną (np. kde4applications), a następnie całą grupę dodać do pliku /etc/pacman.conf w pozycji IgnoreGroup. Będzie to wyglądać mniej więcej tak:
1. W PKGBUILD:
groups = ('kde4applications')2. W /etc/pacman.conf
IgnoreGroup = kde4applications

 

Polityka cookies
Darmowe Fora | Darmowe Forum
polishmasters zielone-wzgorze etavlon dzikie-koty abnormes