Ankieta

Czy chcesz umieszczenia PKGBUILDów dla Krusadera KF5, wiedząc, że budowa jest dość skomplikowana?

Tak
2 (66.7%)
Nie
1 (33.3%)

Głosów w sumie: 3

Autor Wątek: Krusader na KF5  (Przeczytany 1846 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 917
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Krusader na KF5
« dnia: Kwiecień 13, 2015, 12:15:38 »
Z uwagi na rozpoczęcie jakiś czas temu procesu forkowania Krusadera do KF5, aplikacja ta (odpowiadająca mniej więcej wersji 2.4.0 Beta 3) daje się zbudować w oparciu o KF5, w zasadzie bez zależności do bibliotek KDE4 (choć dalej używa kdelibs4support). Wymaga to jednak nieco pracy i budowy kilku innych paczek opartych o KF5, które co najmniej do KDE Applications 15.08 nie będą jeszcze dostępne w stabilnym repozytorium KDE.
Jeśli jednak jesteście zainteresowani - zamieściłem odpowiednią ankietę.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 917
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Krusader na KF5
« Odpowiedź #1 dnia: Maj 26, 2015, 17:48:44 »
Jedynie 3 głosy - zatem nie bardzo mi się chce, zwłaszcza, że w międzyczasie:
yaourt - S krusader-frameworks-git

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 917
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Krusader na KF5
« Odpowiedź #2 dnia: Lipiec 29, 2015, 07:48:18 »
W międzyczasie, projekt Krusader w całości migrował na Qt5/KF5 (w git, jako główna, rozwijana jest wyłącznie ta wersja, choć wersja kde4 również się tam znajduje), stąd też zmianie uległa nazwa paczki w AUR4. Instalacja (najprościej z użyciem packer/packer-color, bądź ściągamy tarball z AUR4):
packer -S krusader-gitlub ze ściągniętego tarballa:
tar -zxvf krusader-git.tar.gz && cd krusader-git && makepkg -sircDodatkowo pojawiła się paczka lokalizacyjna:
packer -S krusader-l10n-frameworkslub:
tar -zxvf krusader-l10n-frameworks.tar.gz && cd krusader-l10n-frameworks && makepkg -sirc
Program otrzymuje dość dużą ilość commitów tygodniowo, wobec powyższego zalecam jego aktualizację powiedzmy raz na tydzień (lub jeśli coś nie działa - choć obecnie nie obserwuję czegoś takiego - nawet częściej). Commity można sprawdzić pod adresem:
http://quickgit.kde.org/?p=krusader.git&a=shortlog
« Ostatnia zmiana: Lipiec 29, 2015, 17:40:16 wysłana przez sir_lucjan »

 

Polityka cookies
Darmowe Fora | Darmowe Forum
world-of-dogs kwietniowki2011 off-road4x4wiki horsesgame moonlights