Ostatnie wiadomości

Strony: [1] 2 3 ... 10
1
POLAUR / Odp: QMPlay2 dla Qt5
« Ostatnia wiadomość wysłana przez pavbaranov dnia Grudzień 27, 2015, 01:44:05 »
W AUR znajduje się skrypt budujący paczkę qmplay2-git, która odpowiada skryptom, które dotychczas tutaj prezentowałem. Przestaję zatem je kontynuować.
Instalacja qmplay2-git będzie od Was wymagała odinstalowania pakietu qmplay2-qt5 (bowiem takiego qmplay2-git nie zna). Możemy to zrobić albo tradycyjnie z użyciem pacmana, albo podczas budowy pakietu zmienić plik PKGBUILD i umieścić w nim:
conflicts=('qmplay2' 'qmplay2-qt5')w miejsce:
conflicts=('qmplay2')
2
POLAUR / Odp: Otter-Browser nowe wcielenie
« Ostatnia wiadomość wysłana przez pavbaranov dnia Grudzień 16, 2015, 09:14:31 »
Prawie jak Rudy. Wersja #102:
PKGBUILD dla qtwebkit:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.09
_weekver=102
_pkgname=otter-browser-webkit-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.*' 'otter-browser-beta*')
provides=('otter-browser*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('b5d52d8b12998827cbb027977ce71840')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
PKGBUILD dla qtwebengine:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.09
_weekver=102
_pkgname=otter-browser-webengine-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebengine version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine>=5.5' 'qt5-script>=5.5' 'qt5-multimedia>=5.5' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools>=5.5')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser*' 'otter-browser-beta*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('b5d52d8b12998827cbb027977ce71840')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtwebengine=ON
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
3
POLAUR / Odp: Alexandra - program do katalogowania filmów
« Ostatnia wiadomość wysłana przez pavbaranov dnia Grudzień 10, 2015, 11:34:18 »
Od jakiegoś czasu dostępna jest wersja 1.4.0, ale dopiero teraz udało mi się ją zbudować. Oto PKGBUILD:
# Maintainer: pavbaranov

pkgname=alexandra
pkgver=1.4.0
pkgrel=1
pkgdesc="Video Library"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('libmediainfo' 'qt5-base')
makedepends=('git' 'qt5-base')
install=$pkgname.install
url="http://alexandra-qt.sourceforge.net/en/home/"
source=('https://github.com/jeka-js/alexandra/archive/1.4.0.tar.gz')

sha256sums=('c2a43d3c67c08c9b5c942519f35acb5a098992c2047386ebec40c7b033648bdf')

build() {
    cd "$pkgname-$pkgver/"
    qmake-qt5 PREFIX=/usr .
    make
    }

package(){
    cd $srcdir/$pkgname-$pkgver/src/
    install -Dm 755 -p ${pkgname} ${pkgdir}/usr/bin/${pkgname}
    cd $srcdir/$pkgname-$pkgver
    install -Dm 0644 -p linux/alexandra.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
    install -Dm 644 -p linux/alexandra_addfilms.desktop ${pkgdir}/usr/share/applications/alexandra_addfilms.desktop
    install -Dm 644 -p linux/alexandra.png ${pkgdir}/usr/share/icons/$pkgname.png
    install -Dm 644 -p linux/alexandra.svg ${pkgdir}/usr/share/icons/hicolor/scalable/apps/$pkgname.svg
    }
4
POLAUR / Odp: Tellico-KF5-git
« Ostatnia wiadomość wysłana przez pavbaranov dnia Grudzień 08, 2015, 05:46:33 »
Aktualny PKGBUILD wykorzystujacy libksane 15.11.90 (lub niebawem 15.12):
# Maintainer: pavbaranov
pkgname=tellico-git
pkgver=2.9.90+git.r2196.aef579b
pkgrel=1
pkgdesc="A collection manager build against KDE Frameworks 5 and Qt5"
arch=('i686' 'x86_64')
url="http://tellico-project.org/"
license=("GPL2")
depends=('qt5-base' 'qt5-xmlpatterns' 'kxmlgui' 'kdelibs4support' 'kconfig' 'kconfigwidgets' 'khtml' 'kcoreaddons'
'kdbusaddons' 'ki18n' 'kiconthemes' 'kio' 'kjobwidgets' 'kwidgetsaddons' 'knotifications' 'gettext'
'libxml2' 'libxslt' 'kxmlgui' 'kjobwidgets' 'kcodecs' 'taglib' 'libksane >=15.11.90' 'exempi' 'libdiscid' 'libcsv' 'btparse' 'yaz'
'qimageblitz-qt5-svn' 'exempi')
makedepends=("git" "extra-cmake-modules" "kdoctools" "automoc4")
provides=('tellico')
conflicts=('tellico' 'tellico-git' 'tellico-frameworks-git')
install=${pkgname}.install
source=("git://anongit.kde.org/tellico.git")
#_gitroot="git://anongit.kde.org/tellico"
_gitname="tellico"
sha256sums=('SKIP')

pkgver() {
  cd tellico
#  printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
  _ver="$(cat CMakeLists.txt | grep -e TELLICO_VERSION | head -n3 | cut -d '"' -f2)"
  echo "$(echo ${_ver} | tr ' ' .).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}

prepare() {
  mkdir -p build
}

build() {
  cd build
    cmake ../tellico \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_BUILD_TYPE=Release \
    -DLIB_INSTALL_DIR=lib \
        -DQT_PLUGIN_INSTALL_DIR=lib/qt/plugins \
    -DKDE_INSTALL_USE_QT_SYS_PATHS=ON

  make
}

package() {
  cd build
  make DESTDIR="$pkgdir" install

# fix python 2.7 path
  find "${pkgdir}" -iname "*.py" | xargs sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|'
}
Paczka libksane dostępna jest w repozytorium kde-unstable (niebawem winna - w wersji 15.12 - trafić do repozytorium testing, a potem extra Archa). Możemy ją zainstalować z jakiejkolwiek lokalizacji jakiegokolwiek serwera udostępniającego Archa. Możemy również zdecydować się na używanie kde-unstable. Więcej o tym ostatnim piszę tu: http://linux-pavbaranov.blogspot.com/2015/12/wiecej-aplikacji-na-kf5-mniej-kompilacji.html
5
POLAUR / Odp: Otter-Browser nowe wcielenie
« Ostatnia wiadomość wysłana przez pavbaranov dnia Grudzień 08, 2015, 03:55:40 »
Pierwsze wydanie z serii 0.9.09, czyli wersja tygodniowa 101:
PKGBUILD wersji z qtwebkit:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.09
_weekver=101
_pkgname=otter-browser-webkit-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.*' 'otter-browser-beta*')
provides=('otter-browser*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('023b1600b73eb95fb42abc301a225ea2')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
PKGBUILD wersji z qtwebengine:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.09
_weekver=101
_pkgname=otter-browser-webengine-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebengine version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine>=5.5' 'qt5-script>=5.5' 'qt5-multimedia>=5.5' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools>=5.5')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser*' 'otter-browser-beta*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('023b1600b73eb95fb42abc301a225ea2')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtwebengine=ON
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
6
POLAUR / Odp: QMPlay2 dla Qt5
« Ostatnia wiadomość wysłana przez pavbaranov dnia Grudzień 07, 2015, 21:47:05 »
PKBUILD dla wersji 15.12.06:
# Contributer: giacomogiorgianni@gmail.com
# Maintainer for Qt5 version: pavbaranov

# Full pkgname # Do not edit below this line unless you know what you're doing
#
#_pkgname=qmplay2-qt5
#
###################################

pkgname=qmplay2-qt5
#__pkgname=qmplay2
pkgver=15.12.06
pkgrel=1
pkgdesc="QMPlay2 is a video player, it can plays all formats and stream supported by ffmpeg and libmodplug (including J2B). It has integrated Youtube browser. Qt5 version."
arch=('i686' 'x86_64')
url="http://qt-apps.org/content/show.php/QMPlay2?content=153339"
license=('GPL v.3')
depends=('qt5-base' 'qt5-x11extras' 'libdbusmenu-qt5' 'ffmpeg' 'libass' 'mesa' 'libva' 'libxv'
'libcdio' 'libxkbcommon-x11' 'taglib' 'libcdio' 'libcddb' 'libpulse')
optdepends=('pulseaudio' 'youtube-dl' 'pulseaudio-alsa')
makedepends=('make' 'gcc')
conflicts=('qmplay2')
source=("http://sourceforge.net/projects/zaps166/files/QMPlay2/QMPlay2-src-${pkgver}.tar.xz")
md5sums=('3d6fa37eaefcf122a04b6544b9a01ec1')

build()
{
        cd $srcdir/QMPlay2-src-$pkgver/
        QT_SUFFIX=-qt5 NOTERM=1 SYSTEM_BUILD=1 ./compile_unix 0
}

package()
{
        mv $srcdir/QMPlay2-src-$pkgver/app $pkgdir/usr
}
7
POLAUR / Odp: Otter-Browser nowe wcielenie
« Ostatnia wiadomość wysłana przez pavbaranov dnia Grudzień 02, 2015, 21:37:44 »
Otter-Browser Beta 8:
PKGBUILD dla qtwebkit:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.08
_pkgname=otter-browser-beta8-qtwebkit

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.*')
provides=('otter-browser*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-beta8/otter-browser-${_pkgver}.tar.bz2")
md5sums=('f6b107391e928c9053f44430a6572b8f')

build() {
  cd ${__pkgname}-${_pkgver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${_pkgver}
  make DESTDIR=$pkgdir install
}
PKGBUILD dla qtwebengine:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.08
_pkgname=otter-browser-beta8-qtwebengine

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.*')
provides=('otter-browser*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-beta8/otter-browser-${_pkgver}.tar.bz2")
md5sums=('f6b107391e928c9053f44430a6572b8f')

build() {
  cd ${__pkgname}-${_pkgver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtwebengine=ON
  make
}

package() {
  cd ${__pkgname}-${_pkgver}
  make DESTDIR=$pkgdir install
}
8
POLAUR / Odp: Otter-Browser nowe wcielenie
« Ostatnia wiadomość wysłana przez pavbaranov dnia Grudzień 01, 2015, 11:10:26 »
Doczekaliśmy się okrągłego wydania 100:
PKGBUILD dla qtwebkit:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.08
_weekver=100
_pkgname=otter-browser-webkit-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.*' 'otter-browser-beta*')
provides=('otter-browser*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('33fadb0aca3de5906442eace3a2dbfdf')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
PKGBUILD dla qtwebengine:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.08
_weekver=100
_pkgname=otter-browser-webengine-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebengine version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine>=5.5' 'qt5-script>=5.5' 'qt5-multimedia>=5.5' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools>=5.5')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser*' 'otter-browser-beta*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('d4c90b5780363ef84ce43b765bd6e4d8')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtwebengine=ON
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
9
POLAUR / Odp: Otter-Browser nowe wcielenie
« Ostatnia wiadomość wysłana przez pavbaranov dnia Listopad 25, 2015, 09:40:48 »
Wersja #99:
PKGBUILD dla wersji opartej o qtwebkit:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.08
_weekver=99
_pkgname=otter-browser-webkit-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.*' 'otter-browser-beta*')
provides=('otter-browser*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('d4c90b5780363ef84ce43b765bd6e4d8')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
PKGBUILD wersji opartej o qtwebengine:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.08
_weekver=99
_pkgname=otter-browser-webengine-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebengine version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine>=5.5' 'qt5-script>=5.5' 'qt5-multimedia>=5.5' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools>=5.5')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser*' 'otter-browser-beta*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('d4c90b5780363ef84ce43b765bd6e4d8')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtwebengine=ON
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
10
POLAUR / Odp: Otter-Browser nowe wcielenie
« Ostatnia wiadomość wysłana przez pavbaranov dnia Listopad 18, 2015, 09:42:55 »
Wersja #98:
PKGBUILD dla qtwebkit:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.08
_weekver=98
_pkgname=otter-browser-webkit-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.*' 'otter-browser-beta*')
provides=('otter-browser*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('473da4b0f8bef4e3028179733ba2e713')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
PKGBUILD dla qtwebengine:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.08
_weekver=98
_pkgname=otter-browser-webengine-weekly

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver.$_weekver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebengine version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine>=5.5' 'qt5-script>=5.5' 'qt5-multimedia>=5.5' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools>=5.5')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser*' 'otter-browser-beta*')
install=otter.install
source=("http://sourceforge.net/projects/otter-browser/files/otter-browser-weekly${_weekver}/otter-browser-${_pkgver}-dev${_weekver}.tar.bz2")
md5sums=('473da4b0f8bef4e3028179733ba2e713')

build() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtwebengine=ON
  make
}

package() {
  cd ${__pkgname}-${_pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
Strony: [1] 2 3 ... 10
Polityka cookies
Darmowe Fora | Darmowe Forum
ostwalia meute-de-loups kibiceodry sp357klasa1g skylife