Autor Wątek: Otter-Browser nowe wcielenie  (Przeczytany 16508 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Otter-Browser nowe wcielenie
« dnia: Grudzień 18, 2014, 00:11:40 »
Od jakiegoś czasu Otter-Browser jest wydawany w cotygodniowych buildach. Niestety w AUR jest nieco spóźniona wersja. Poniżej PKGBUILD umożliwiający budowę wersji weekly50.
PKGBUILD
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov

pkgname=otter-browser
pkgver=0.9.04
pkgrel=1
weekver=dev50
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git')
install=otter.install
source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}-weekly50/${pkgname}-${pkgver}-${weekver}.tar.bz2")
md5sums=('f2b1cd985131044e70503edfb4626bbc')

build() {
  cd ${pkgname}-${pkgver}-${weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${pkgname}-${pkgver}-${weekver}
  make DESTDIR=$pkgdir install
}

W przyszłym tygodniu będzie to wersja 51 itd. Prawdopodobnie w styczniu pojawi się wersja 0.9.5. Łatwo możemy dostosować ten PKGBUILD do kolejnych wydań. Oczywiście wpierwsz sprawdzamy na http://sourceforge.net/projects/otter-browser/files/ Jeśli pojawia się nowa wersja tygodniowa, to w polu:
weekdev zmieniamy cyfrę 50 na odpowiadającą tej wersji (np. 51)
i ewentualnie zmieniamy numer wersji, czyli pkgver na tę, która będzie figurować w nazwie Otter Browsera. Oczywiście nie zapominamy wykonać updpkgsums.

Plik otter-browser.install (stały dla wszystkich wydań PKGBUILDów):
otter.install
post_install() {
  update-desktop-database -q
  update-mime-database usr/share/mime > /dev/null
  gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
}

post_upgrade() {
  post_install
}

post_remove() {
  post_install
}
należy również pobrać i umieścić w tym samym katalogu, w którym budowany jest Otter-Browser.
« Ostatnia zmiana: Styczeń 13, 2015, 22:12:22 wysłana przez pavbaranov »

greywolf

  • Nowy użytkownik
  • *
  • Wiadomości: 11
  • Reputacja +0/-0
  • Leśny Człowiek
  • Architektura: x86_64
  • DE/WM: Gnome 3.14
  • Distro: Arch Linux
  • GPU: Nvidia non-free
  • Kernel: 3.18
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #1 dnia: Grudzień 21, 2014, 21:56:57 »
hm..  a to nie lepiej zainstalować paczkę otter-browser-git ? i tylko co jakiś czas instalować ponownie? Ja tak robię od ~3 miesięcy i działa ;)
(…) the Linux philosophy is 'laugh in the face of danger'. Oops. Wrong one. 'Do it yourself'. That’s it.

Linus Torvalds

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #2 dnia: Grudzień 21, 2014, 22:23:11 »
Może i lepiej. Z jakiegoś względu jednak, twórcy Otter-Browser wydają cotygodniowe migawki. Jeśli ktoś chce taką mieć nie widzę problemu, dla którego nie miałbym mu tego udostępnić.

PS: Co Twój wpis ma wspólnego z:
- jakością PKGBUILDa?
- jego poprawnością?
- zgłoszeniem nowej wersji devX?

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #3 dnia: Grudzień 23, 2014, 20:32:28 »
Podbijam wersję do 51 tygodnia i zmieniam nieco PKGBUILD - od teraz będzie łatwiej zmieniać wersje, aczkolwiek nie jest to w 100% zgodne z "filozofią Archa" (ale ja nie jestem filozofem ;)).
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer for weekly version: pavbaranov

pkgname=otter-browser
pkgver=0.9.04
pkgrel=2
_weekver=51
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git')
install=otter.install
source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}-weekly${_weekver}/${pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('ed28b280424cfef0745265541b4cffcf')

build() {
  cd ${pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}

greywolf

  • Nowy użytkownik
  • *
  • Wiadomości: 11
  • Reputacja +0/-0
  • Leśny Człowiek
  • Architektura: x86_64
  • DE/WM: Gnome 3.14
  • Distro: Arch Linux
  • GPU: Nvidia non-free
  • Kernel: 3.18
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #4 dnia: Grudzień 23, 2014, 21:42:02 »
Nie doczytałem po prostu o co dokładnie chodziło... tak to jest jak się czyta "w biegu" :P
(…) the Linux philosophy is 'laugh in the face of danger'. Oops. Wrong one. 'Do it yourself'. That’s it.

Linus Torvalds

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #5 dnia: Grudzień 30, 2014, 13:57:15 »
Pojawiła się 52 migawka tygodniowa, zatem nowy PKGBUILD:

Zmieniłem "nazewnictwo". Od tej pory pkgrel będzie odpowiadać numerowi wersji tygodniowej, zatem obecne wydanie będzie nosiło numer 0.9.04-52
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov

pkgname=otter-browser
pkgver=0.9.04
pkgrel=52
_weekver=52
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git')
install=otter.install
source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}-weekly${_weekver}/${pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('139f22737a47749851a7c87b09c6c372')

build() {
  cd ${pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}

I informacja o zmianach:
Cytuj
Weekly report #52 (29-12-2014)
Still better than average week:
23 commits by two authors,
two proposed pull requests,
nine new issues (14 closed),
114 issues still open (including 14 bugs).
Highlights:
total overhaul of internal architecture of actions (there are still few rough edges to be fixed),
no more error 203 when accessing media files directly,
allow to open files from Transfers Manager in selected application (just for Windows right now, other platforms will follow).
Known issues:
configuration dialog for keyboard shortcuts is partially disabled,
some of actions don't have proper state (might be disabled or enabled all the time).

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #6 dnia: Styczeń 02, 2015, 20:31:10 »
Otter-Browser 0.9.04-beta4.
PKGBUILD:
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov

pkgname=otter-browser
pkgver=0.9.04.beta4
pkgrel=1
_weekver=
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git')
install=otter.install
source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
#source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}-weekly${_weekver}/${pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('69a22c896e9b540d5ee9892b242962cf')

build() {
  cd ${pkgname}-0.9.04
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${pkgname}-0.9.04
  make DESTDIR=$pkgdir install
}

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #7 dnia: Styczeń 06, 2015, 17:44:45 »
Oj dziwnie idą te tygodnie w Otter-Browser, ale prezentuję wersję weekly53

EDIT:
Poniżej zamieszczam nowy PKGBUILD albowiem ten, który był, był niestety błędny. Obecna wersja to 0.9.05. Dostosowałem (dzięki pomocy Lucka) nazewnictwo do upstreamu. Teraz paczka tygodniowa będzie nosić nazwę otter-browser-NUMER_WYDANIA-dev-NUMER_TYGODNIA.

PKGBUILD
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=53
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser')
install=otter.install
#source=("http://sourceforge.net/projects/${_pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('6b63ff365497194d8675d63c8a1b947e')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
« Ostatnia zmiana: Styczeń 08, 2015, 16:58:04 wysłana przez pavbaranov »

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #8 dnia: Styczeń 13, 2015, 20:35:12 »
Dzisiaj ukazała się wersja weekly#54 z serii 0.9.05. Wersja ta - jak stwierdza sam emdek jest wersją eksperymentalną. M.in. rozpoczyna wsparcie (jak na razie jako eksperyment właśnie) QtWebEngine (czyli Blink), który jest znany z Google Chrome. Jeśli się nie mylę, to oznacza to m.in., że pliki flash mogą być odtwarzane z użyciem Pepper Flash, a nie Adobe Flash.
Przy okazji PKGBUILD został delikatnie zmodyfikowany.
PKGBUILD
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov (for weekly version)
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=54
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-53')
install=otter.install
#source=("http://sourceforge.net/projects/${_pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('6f17706e43e0d29fcffb391316e7ac59')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
PS: Bardzo prosiłbym osoby, które mają komputery oparte o AMD Ex o uwagi, czy paczka ta buduje się u nich.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #9 dnia: Styczeń 20, 2015, 15:29:15 »
PKGBUILD dla wersji Weekly 55
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=55
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-*')
install=otter.install
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('34906123b1bbd29224a6856e1d5b294a')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
« Ostatnia zmiana: Styczeń 20, 2015, 17:08:18 wysłana przez pavbaranov »

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #10 dnia: Styczeń 20, 2015, 15:57:19 »
Poniżej przedstawiam PKGBUILD dla wersji wykorzystującej inny silnik (czyli Blink znany z Chrome/-ium). Prosiłbym o sprawdzenie, czy bez chromium-pepper-flash da się uruchamiać filmy w flv.
Przypominam - od wersji weekly 54, Otter Browser może być budowany albo z wykorzystaniem qt5-webkit albo z qt5-webengine. Pierwszy silnik znany jest choćby z Rekonq czy Qupzilli. Drugi - jak wspomniałem z Chrome/-ium (choć tutaj nie w wersji qt5).
Obecne PKGBUILDy nie umożliwiają zainstalowania obok siebie obu wersji Ottera. Jeśli zbudowaliśmy wersję opartą o qt5-webkit to makepkg również stwierdzi, że paczka została już zbudowana i będzie chciał ją zainstalować. Nie widzę bowiem powodu, dla którego miałbym rozróżniać nazwy dla obu wersji. To do Was należy wybór, którą wersję chcecie zbudować. Przedstawiony PKGBUILD ma natomiast inną nazwę pliku. Przypominam, że jeśli jego zawartość również nazwiecie sobie jakoś inaczej, to budować pakiet z takiego pliku trzeba wprowadzając jego nazwę:
makepkg -p NAZWAPKGBUILD.qtwebengine
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=55
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme'
'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-*')
install=otter.install
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('34906123b1bbd29224a6856e1d5b294a')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtWebEngine=ON
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
« Ostatnia zmiana: Styczeń 20, 2015, 17:08:34 wysłana przez pavbaranov »

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #11 dnia: Styczeń 27, 2015, 20:53:44 »
Pojawiła się 56 wersja tygodniowa. Poniżej PKGBUILDy dla obu, mozliwych wersji (qtwebkit i qtwebengine). Dopóki nie poprawię PKGBUILDu proszę o odinstalowanie wersji - odpowiednio - qtwebkit bądź qtwebengine, jeśli nowo instalowana wersja ma się opierać na innym silniku.
PKGBUILD.qtwebkit
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=56
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-*')
install=otter.install
#source=("http://sourceforge.net/projects/${_pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('1cd0dd4e79907e07638c596c700cc7c0')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}

PKGBUILD.qtwebengine
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=56
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme'
'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-*')
install=otter.install
#source=("http://sourceforge.net/projects/${_pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('1cd0dd4e79907e07638c596c700cc7c0')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtWebEngine=ON
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
« Ostatnia zmiana: Styczeń 27, 2015, 23:51:54 wysłana przez marcin82 »

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #12 dnia: Luty 06, 2015, 07:58:09 »
Pojawiła się wersja #57 także z nowymi funkcjami: http://otter-browser.org/ zatem podaję PKGBUILDy dla obu możliwych wersji:
PKGBUILD.qtwebkit
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=57
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-*')
install=otter.install
#source=("http://sourceforge.net/projects/${_pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('44f09adb92e5727fefde235889d791b6')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
PKGBUILD.qtwebengine
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=57
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebengine version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme'
'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-*')
install=otter.install
#source=("http://sourceforge.net/projects/${_pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('44f09adb92e5727fefde235889d791b6')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtWebEngine=ON
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
Przypominam, że dopóki nie zrobię z tym porządku (pewnie w przyszłym tygodniu) to przed instalacją należy odinstalować wersję znajdującą się w systemie (opcja -R).

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #13 dnia: Luty 11, 2015, 10:44:17 »
Ukazała się wersja weekly58, zatem podaję poniżej oba możliwe PKGBUILDy. Niestety w dalszym ciągu nie poprawiłem PKGBUILDów, zatem przed instalacją nowej wersji, proszę o usunięcie starej za pomocą pacmana (opcja -R).
PKGBUILD.qtwebkit
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=58
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-*')
install=otter.install
#source=("http://sourceforge.net/projects/${_pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('37701a6fef5518264b558aa0063e4577')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}
PKGBUILD.qtwebengine
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=58
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebengine version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme'
'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9.05-dev-*')
install=otter.install
#source=("http://sourceforge.net/projects/${_pkgname}/files/${pkgname}-beta4/${pkgname}-0.9.04.tar.bz2")
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('37701a6fef5518264b558aa0063e4577')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtWebEngine=ON
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Otter-Browser nowe wcielenie
« Odpowiedź #14 dnia: Luty 19, 2015, 09:57:25 »
Udostępniona została 59 wersja tygodniowa Ottera: http://otter-browser.org/ Oba możliwe PKGBUILDy prezentuję niżej. Wciąż też przypominam, że zapominam dostosować je w taki sposób, by instalacja nowej wersji zastępowała starą, stąd też, jeśli i o ile ktoś używa, to powinien wpierw odinstalować Ottera i zainstalować paczkę zbudowaną wg prezentowanych tu PKGBUILDów albo zbudować, a następnie zainstalować z opcją --force.

PKGBUILD.qtwebkit
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=59
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebkit version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webkit' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9*')
install=otter.install
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('c8ec44d9c2f27df1fefde3f51e127cbf')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr"
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}

PKGBUILD.qtwebengine
# Maintainer: boenki <boenki at gmx dot de>
# Maintainer: pavbaranov
# Contributor: sir_lucjan

# Full pkgname # Do no edit below this line unless you know what you're doing

_pkgver=0.9.05
_weekver=59
_pkgname=otter-browser-$_pkgver-dev-$_weekver

################################################

pkgname=$_pkgname
__pkgname=otter-browser
pkgver=$_pkgver
weekver=$_weekver
pkgrel=1
pkgdesc="Browser aiming to recreate classic Opera (12.x) UI using Qt5 - qtwebengine version."
arch=('i686' 'x86_64')
url="http://$pkgname.org"
license=('GPL3')
depends=('qt5-webengine' 'qt5-script' 'qt5-multimedia' 'hicolor-icon-theme' 'desktop-file-utils')
makedepends=('cmake' 'qt5-tools')
conflicts=('otter-browser-git' 'otter-browser' 'otter-browser-0.9*')
install=otter.install
source=("http://sourceforge.net/projects/${__pkgname}/files/${__pkgname}-weekly${_weekver}/${__pkgname}-${pkgver}-dev${_weekver}.tar.bz2")
md5sums=('c8ec44d9c2f27df1fefde3f51e127cbf')

build() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  lrelease resources/translations/*.ts
  cmake -DCMAKE_INSTALL_PREFIX="/usr" \
        -DEnableQtWebEngine=ON
  make
}

package() {
  cd ${__pkgname}-${pkgver}-dev${_weekver}
  make DESTDIR=$pkgdir install
}

 

Polityka cookies
Darmowe Fora | Darmowe Forum
etavlon rasa-nocna polishmasters chopin zielone-wzgorze