Autor Wątek: Repozytorium Arch-Like  (Przeczytany 2906 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

sir_lucjan

  • AUR-OR
  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 1327
  • Reputacja +11/-0
  • Nic nie działa, jak Polska cała!
    • Mój profil w AUR
  • Architektura: x86_64
  • DE/WM: Plasma 5
  • Distro: Arch Linux
  • GPU: Intel
  • Kernel: linux-bfq-haswell
Repozytorium Arch-Like
« dnia: Styczeń 08, 2015, 15:24:55 »
Witajcie.

Udało mi się uruchomić repozytorium Arch-Like. Póki co zapaczkowane są w nim aplikacje dla KDE oznaczone numerem 14.12. Są to aplikacje przeznaczone zarówno dla KDE4 (repo kde4last) jak i dla nowego KDE (repo kde-next). Póki co wszystko zrobione jest bardzo prowizorycznie - ale działa i to jest najważniejsze. Jeśli jesteście zainteresowani, dodajcie do pliku /etc/pacman.conf:

[kde4last]
Server = https://sourceforge.net/projects/arch-like/files/repo/kde4last/

[kde-next]
Server = https://sourceforge.net/projects/arch-like/files/repo/kde-next/

Aplikacje są tylko i wyłącznie w 64 bitowej wersji. Póki co brakuje także podpisów paczek - ale skoro w repozytoriach niektórych developerów oraz zaufanych użytkowników także tego nie ma (np. heftig czy mesa-git), czujemy się rozgrzeszeni. Zapraszam do korzystania i zgłaszania ewentualnych błędów!
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661
[AUR]  [GitHub]

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Repozytorium Arch-Like
« Odpowiedź #1 dnia: Styczeń 08, 2015, 15:50:00 »
I jeszcze jedno - prosimy te wersje traktować jako testowe. Chcielibyśmy poznać Wasze zdanie, a przede wszystkim, czy te paczki się sprawdzają. Jeśli tak.... :D

sir_lucjan

  • AUR-OR
  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 1327
  • Reputacja +11/-0
  • Nic nie działa, jak Polska cała!
    • Mój profil w AUR
  • Architektura: x86_64
  • DE/WM: Plasma 5
  • Distro: Arch Linux
  • GPU: Intel
  • Kernel: linux-bfq-haswell
Odp: Repozytorium Arch-Like
« Odpowiedź #2 dnia: Styczeń 08, 2015, 15:52:09 »
Paweł odpowiada za paczki dla nowego KDE, ja za te przeznaczone dla KDE4 (z wyjątkiem kpatience i oxygen-icons).
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661
[AUR]  [GitHub]

greh

  • Admin honorowy im. Huberta Dwornioka
  • Użytkownik
  • *****
  • Wiadomości: 57
  • Reputacja +4/-2
  • Przez takich jak wy w reaktorach szaleją jądra.
  • Architektura: x86_64
  • DE/WM: Cinnamon
  • Distro: Antergos
  • GPU: Radeon free + Nvidia free
  • Kernel: 4.1.2-2-ARCH
Odp: Repozytorium Arch-Like
« Odpowiedź #3 dnia: Styczeń 08, 2015, 16:02:47 »
Fajna sprawa. Gratulacje.  ;)
A byłaby szansa na paczki dla nie KDE? ;)
Oczywiście nie mówię, że już, teraz, natychmiast. W jakiejś bliżej nieokreślonej przyszłości.  :)

sir_lucjan

  • AUR-OR
  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 1327
  • Reputacja +11/-0
  • Nic nie działa, jak Polska cała!
    • Mój profil w AUR
  • Architektura: x86_64
  • DE/WM: Plasma 5
  • Distro: Arch Linux
  • GPU: Intel
  • Kernel: linux-bfq-haswell
Odp: Repozytorium Arch-Like
« Odpowiedź #4 dnia: Styczeń 08, 2015, 16:13:47 »
Zaproponuj coś.
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661
[AUR]  [GitHub]

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Repozytorium Arch-Like
« Odpowiedź #5 dnia: Styczeń 08, 2015, 16:41:56 »
Nawet masz stosowny wątek: http://www.archlike.darmowefora.pl/index.php/topic,172.0.html
Inna sprawa, że zarówno Lucek, jak i ja mamy KDE (jak na razie Lucjan w wersji 4.x, ja mam Plasmę 5, zatem ja nie jestem w stanie zbudować niektórych paczek dla KDE4, a Lucek na Plasmę 5) i pewnie nie bardzo będzie nam się chciało ściągać całe środowiska, by kompilować. Niemniej jednak - jeśli się tylko da - udostępnimy (jak mawia Mój Wielki Mistrz :)) PKGBUILDy oraz inne skrypty umożliwiające kompilację takiej paczki w POLAUR (nb. właśnie w tym miejscu są skrypty budujące paczki w repo) i jeśli masz np. Cinnamona, to będziesz mógł zbudować taką paczkę, a potem możemy ją wrzucić na repo. Wówczas powstanie jakieś "inne".
W wątku "Potrzebuję" dobrze by było, abyście umieszczali właśnie propozycje dla takich paczek. My przecież nie wiemy co potrzebujecie. Inna sprawa, że jeśli jest jakiś działający "AUR", to pewnie nie będziemy robić specjalnie paczki, skoro można sobie ją skompilować we własnym zakresie. Od tego są inne repozytoria.
Zastanawiamy się również, czy - wyłącznie testowo (czyli dla ograniczonego grona) - nie udostępniać paczek, z którymi się np. Arch spóźnia (np. ja mam zbudowane wszystkie paczki KF5.6 i KF5.6-Aids). Zdarza się bowiem, że wersje, które są w repozytoriach uniemożliwiają budowę jakichś paczek z AUR, szczególnie w wersjach *-git. Inna sprawa, że... KF5.6 dla dwu paczek okazało się być zbyt nowe, bowiem wersje tych aplikacji na Gicie KDE są jeszcze dostosowane do KF5.5. Ot, taki przypadek.

sir_lucjan

  • AUR-OR
  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 1327
  • Reputacja +11/-0
  • Nic nie działa, jak Polska cała!
    • Mój profil w AUR
  • Architektura: x86_64
  • DE/WM: Plasma 5
  • Distro: Arch Linux
  • GPU: Intel
  • Kernel: linux-bfq-haswell
Odp: Repozytorium Arch-Like
« Odpowiedź #6 dnia: Styczeń 08, 2015, 17:51:13 »
Kolejne repo:

[archlike]
Server = https://sourceforge.net/projects/arch-like/files/repo/archlike/

Tutaj lądować będą paczki niezwiązane ze środowiskiem KDE.
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661
[AUR]  [GitHub]

sir_lucjan

  • AUR-OR
  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 1327
  • Reputacja +11/-0
  • Nic nie działa, jak Polska cała!
    • Mój profil w AUR
  • Architektura: x86_64
  • DE/WM: Plasma 5
  • Distro: Arch Linux
  • GPU: Intel
  • Kernel: linux-bfq-haswell
Odp: Repozytorium Arch-Like
« Odpowiedź #7 dnia: Styczeń 09, 2015, 12:18:35 »
Dodaliśmy co nieco do repo archike:

https://sourceforge.net/projects/arch-like/files/repo/archlike/

Miłego korzystania!
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661
[AUR]  [GitHub]

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Repozytorium Arch-Like
« Odpowiedź #8 dnia: Styczeń 09, 2015, 14:09:24 »
To gwoli wyjaśnienia, co gdzie będziecie mogli znaleźć:

- repozytorium kde4last
Tutaj znajdziecie aktualizacje programów, składających się na to środowisko i dostarczanych przez zespół odpowiadający za tworzenie KDE4 (czyli to, co znajdziecie na kde.org). Obecnie jest to część paczek, które składają się na KDE Applications 14.12. W tej formule, będą tu udostępniane paczki, o ile deweloperzy Archa nie będą budować swoich wersji i jedynie pod tym warunkiem. Innymi słowy, jeśli w repozytoriach Archa pojawią się te aplikacje w wersji (najprawdopodobniej) 14.12.1, to my ich nie będziemy tworzyć, a paczki z tego repozytorium (w wersji 14.12) zostaną usunięte. Jeśli jednak Arch ponownie nie dostarczy paczek w wersjach 14.12.1, to zostaną one zbudowane i udostępnione w ramach tego repozytorium.
Spośród paczek, które składają się na KDE Applications 14.12 w tym repozytorium nie ma i nie będzie nigdy paczek, które zbudowane są z użyciem KDE Framework 5.

- repozytorium kde-next
Tutaj znajdziecie paczki, które można wykorzystać z Plasma 5. Na paczki te składać się będą te aplikacje, które dostarczane są w ramach KDE Applications 14.12, które są budowane z użyciem KDE Framework 5. Te paczki będziemy dostarczać na takich samych warunkach, na jakie obowiązują w przypadku repozytorium kde4last.
Nadto, znajdziecie tutaj np. motywy, plasmoidy, tematy, ikony itp., które nie są obecne w repozytoriach Archa oraz, które nie są dostarczane przez KDE.org. Najczęściej ich źródłem będzie kde-apps.org bądź kde-look.org.
Obecnie, znajduje się tutaj również paczka kde-l10n-pl, choć w zasadzie powinna się ona znaleźć w kde4last. Dzieje się tak, albowiem obecnie funkcjonująca w KDE4 paczka o takiej samej nazwie znacznie lepiej spolszcza to środowisko. kde-l10n-pl z tego repozytorium umożliwia natomiast "dopolszczenie" Plasmy 5.

- repozytorium archlike
Tutaj lądują wszelkie inne programy, które nie są bezpośrednio związane ze środowiskiem KDE4 bądź Plasma 5. Mogą się tutaj znaleźć aplikacje konsolowe oraz działające w trybie graficznym, oparte o dowolny framework obecnie wspierany w ramach Archa (Qt4 i Qt5, Gtk itd.). Ze względu na to, że paczek opartych o Qt3 nie można będzie już używać w środowiskach korzystających z Qt5 (w Qt4 jeszcze można), to żaden z programów w tym repozytorium nie będzie budowany w oparciu o ten framework. W przypadku tego repozytorium nie ma żadnej "pozytywnej" reguły jakiego typu oprogramowanie tutaj się znajdzie - istnieje wyłącznie "negatywna": nie trafi tu to, co wg nas winno trafić do dwu poprzednio omówionych.

EDIT:
Chciałbym także podziękować @dareckiemu za pomoc w testowaniu paczek.
« Ostatnia zmiana: Styczeń 09, 2015, 17:43:45 wysłana przez pavbaranov »

sir_lucjan

  • AUR-OR
  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 1327
  • Reputacja +11/-0
  • Nic nie działa, jak Polska cała!
    • Mój profil w AUR
  • Architektura: x86_64
  • DE/WM: Plasma 5
  • Distro: Arch Linux
  • GPU: Intel
  • Kernel: linux-bfq-haswell
Odp: Repozytorium Arch-Like
« Odpowiedź #9 dnia: Styczeń 09, 2015, 20:50:22 »
Paczki dla KDE4 są chyba w całości.

[lucjan@archlinux ~]$ pacman -Sl kde4last | wc -l
147
[lucjan@archlinux ~]$ pacman -Sl kde4last
kde4last kde-base-artwork 14.12.0-1 [zainstalowano]
kde4last kdeaccessibility-jovie 14.12.0-1
kde4last kdeaccessibility-kaccessible 14.12.0-1
kde4last kdeaccessibility-kmag 14.12.0-1
kde4last kdeaccessibility-kmousetool 14.12.0-1
kde4last kdeaccessibility-kmouth 14.12.0-1
kde4last kdeadmin-kcron 14.12.0-1
kde4last kdeadmin-ksystemlog 14.12.0-1
kde4last kdeadmin-kuser 14.12.0-1
kde4last kdeartwork-colorschemes 14.12.0-1
kde4last kdeartwork-desktopthemes 14.12.0-1
kde4last kdeartwork-emoticons 14.12.0-1
kde4last kdeartwork-iconthemes 14.12.0-1                                                                                                                                                       
kde4last kdeartwork-kscreensaver 14.12.0-1                                                                                                                                                     
kde4last kdeartwork-styles 14.12.0-1                                                                                                                                                           
kde4last kdeartwork-wallpapers 14.12.0-1                                                                                                                                                       
kde4last kdeartwork-weatherwallpapers 14.12.0-1                                                                                                                                                 
kde4last kdebase-dolphin 14.12.0-1 [zainstalowano]                                                                                                                                             
kde4last kdebase-kdepasswd 14.12.0-1 [zainstalowano]                                                                                                                                           
kde4last kdebase-kdialog 14.12.0-1 [zainstalowano]
kde4last kdebase-keditbookmarks 14.12.0-1 [zainstalowano]
kde4last kdebase-kfind 14.12.0-1 [zainstalowano]
kde4last kdebase-konq-plugins 14.12.0-1
kde4last kdebase-konqueror 14.12.0-1
kde4last kdebase-lib 14.12.0-1 [zainstalowano]
kde4last kdebase-plasma 14.12.0-1 [zainstalowano]
kde4last kdebase-runtime 14.12.0-1 [zainstalowano]
kde4last kdeedu-artikulate 14.12.0-1
kde4last kdeedu-blinken 14.12.0-1
kde4last kdeedu-cantor 14.12.0-1
kde4last kdeedu-data 14.12.0-1
kde4last kdeedu-kalzium 14.12.0-1
kde4last kdeedu-kbruch 14.12.0-1
kde4last kdeedu-kgeography 14.12.0-1
kde4last kdeedu-kiten 14.12.0-1
kde4last kdeedu-klettres 14.12.0-1
kde4last kdeedu-kmplot 14.12.0-1
kde4last kdeedu-kstars 14.12.0-1
kde4last kdeedu-ktouch 14.12.0-1
kde4last kdeedu-kturtle 14.12.0-1
kde4last kdeedu-kwordquiz 14.12.0-1
kde4last kdeedu-marble 14.12.0-1
kde4last kdeedu-pairs 14.12.0-1
kde4last kdeedu-rocs 14.12.0-1
kde4last kdeedu-step 14.12.0-1
kde4last kdegames-bomber 14.12.0-1
kde4last kdegames-bovo 14.12.0-1
kde4last kdegames-kajongg 14.12.0-1
kde4last kdegames-kapman 14.12.0-1
kde4last kdegames-katomic 14.12.0-1
kde4last kdegames-kblackbox 14.12.0-1
kde4last kdegames-kblocks 14.12.0-1
kde4last kdegames-kbounce 14.12.0-1
kde4last kdegames-kbreakout 14.12.0-1
kde4last kdegames-kdiamond 14.12.0-1
kde4last kdegames-kfourinline 14.12.0-1
kde4last kdegames-kgoldrunner 14.12.0-1
kde4last kdegames-kigo 14.12.0-1
kde4last kdegames-killbots 14.12.0-1
kde4last kdegames-kiriki 14.12.0-1
kde4last kdegames-kjumpingcube 14.12.0-1
kde4last kdegames-klickety 14.12.0-1
kde4last kdegames-klines 14.12.0-1
kde4last kdegames-kmahjongg 14.12.0-1
kde4last kdegames-kmines 14.12.0-1
kde4last kdegames-knavalbattle 14.12.0-1
kde4last kdegames-knetwalk 14.12.0-1
kde4last kdegames-kolf 14.12.0-1
kde4last kdegames-kollision 14.12.0-1
kde4last kdegames-konquest 14.12.0-1
kde4last kdegames-kpatience 14.12.0-1
kde4last kdegames-kreversi 14.12.0-1
kde4last kdegames-kshisen 14.12.0-1
kde4last kdegames-ksnakeduel 14.12.0-1
kde4last kdegames-kspaceduel 14.12.0-1
kde4last kdegames-ksquares 14.12.0-1
kde4last kdegames-ksudoku 14.12.0-1
kde4last kdegames-ktuberling 14.12.0-1
kde4last kdegames-lskat 14.12.0-1
kde4last kdegames-palapeli 14.12.0-1
kde4last kdegames-picmi 14.12.0-1
kde4last kdegraphics-kamera 14.12.0-1
kde4last kdegraphics-kcolorchooser 14.12.0-1
kde4last kdegraphics-kgamma 14.12.0-1
kde4last kdegraphics-kolourpaint 14.12.0-1
kde4last kdegraphics-kruler 14.12.0-1
kde4last kdegraphics-ksaneplugin 14.12.0-1
kde4last kdegraphics-ksnapshot 14.12.0-1
kde4last kdegraphics-mobipocket 14.12.0-1 [zainstalowano]
kde4last kdegraphics-okular 14.12.0-1 [zainstalowano]
kde4last kdegraphics-strigi-analyzer 14.12.0-1
kde4last kdegraphics-svgpart 14.12.0-1
kde4last kdegraphics-thumbnailers 14.12.0-1 [zainstalowano]
kde4last kdemultimedia-audiocd-kio 14.12.0-1
kde4last kdemultimedia-dragonplayer 14.12.0-1
kde4last kdemultimedia-ffmpegthumbs 14.12.0-1
kde4last kdemultimedia-juk 14.12.0-1
kde4last kdemultimedia-kmix 14.12.0-1 [zainstalowano]
kde4last kdemultimedia-kscd 14.12.0-1
kde4last kdemultimedia-mplayerthumbs 14.12.0-1
kde4last kdenetwork-filesharing 14.12.0-1
kde4last kdenetwork-kget 14.12.0-1 [zainstalowano]
kde4last kdenetwork-kopete 14.12.0-1 [zainstalowano]
kde4last kdenetwork-kppp 14.12.0-1
kde4last kdenetwork-krdc 14.12.0-1
kde4last kdenetwork-krfb 14.12.0-1
kde4last kdenetwork-strigi-analyzers 14.12.0-1
kde4last kdenetwork-zeroconf-ioslave 14.12.0-1
kde4last kdesdk-cervisia 14.12.0-1
kde4last kdesdk-dev-scripts 14.12.0-1
kde4last kdesdk-dev-utils 14.12.0-1
kde4last kdesdk-dolphin-plugins 14.12.0-1
kde4last kdesdk-kcachegrind 14.12.0-1
kde4last kdesdk-kioslaves 14.12.0-1
kde4last kdesdk-kompare 14.12.0-1 [zainstalowano]
kde4last kdesdk-lokalize 14.12.0-1
kde4last kdesdk-poxml 14.12.0-1
kde4last kdesdk-strigi-analyzers 14.12.0-1
kde4last kdesdk-thumbnailers 14.12.0-1
kde4last kdesdk-umbrello 14.12.0-1
kde4last kdetoys-amor 14.12.0-1
kde4last kdetoys-kteatime 14.12.0-1
kde4last kdetoys-ktux 14.12.0-1
kde4last kdeutils-ark 14.12.0-1 [zainstalowano]
kde4last kdeutils-filelight 14.12.0-1
kde4last kdeutils-kcalc 14.12.0-1 [zainstalowano]
kde4last kdeutils-kcharselect 14.12.0-1 [zainstalowano]
kde4last kdeutils-kdf 14.12.0-1
kde4last kdeutils-kfloppy 14.12.0-1
kde4last kdeutils-kgpg 14.12.0-1
kde4last kdeutils-kremotecontrol 14.12.0-1
kde4last kdeutils-ktimer 14.12.0-1
kde4last kdeutils-kwalletmanager 14.12.0-1
kde4last kdeutils-print-manager 14.12.0-1
kde4last kdeutils-superkaramba 14.12.0-1
kde4last kdeutils-sweeper 14.12.0-1 [zainstalowano]
kde4last libkcddb 14.12.0-1 [zainstalowano]
kde4last libkcompactdisc 14.12.0-1
kde4last libkdcraw 14.12.0-1 [zainstalowano]
kde4last libkdeedu 14.12.0-1
kde4last libkdegames 14.12.0-1
kde4last libkexiv2 14.12.0-1 [zainstalowano]
kde4last libkipi 14.12.0-1 [zainstalowano]
kde4last libkmahjongg 14.12.0-1
kde4last libkomparediff2 14.12.0-1 [zainstalowano]
kde4last libksane 14.12.0-1
kde4last oxygen-icons 14.12.0-1 [zainstalowano]

Pracowity dzień - ale było warto :)
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661
[AUR]  [GitHub]

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Repozytorium Arch-Like
« Odpowiedź #10 dnia: Styczeń 09, 2015, 21:06:55 »
W poniedziałek dojdą nowe.
Przy okazji - dajcie ewentualnie znać, co tam chcielibyście widzieć.

sir_lucjan

  • AUR-OR
  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 1327
  • Reputacja +11/-0
  • Nic nie działa, jak Polska cała!
    • Mój profil w AUR
  • Architektura: x86_64
  • DE/WM: Plasma 5
  • Distro: Arch Linux
  • GPU: Intel
  • Kernel: linux-bfq-haswell
Odp: Repozytorium Arch-Like
« Odpowiedź #11 dnia: Styczeń 11, 2015, 21:13:52 »
Repo kde-next zostało chwilowo wyłączone z przyczyn technicznych - część paczek nie działa tak, jak powinna.

Paczki z kde4last działają świetnie w środowisku KDE4 - z wyjątkiem większości z grupy kdegames oraz kilku z grupy kdeedu - te kompilowane były na "nowym" KDE i nie działają prawidłowo. Na dniach powinna ukazać się wersja 14.12.1 - tutaj wszystkie skompiluję osobiście na KDE4 tak więc wszystko winno działać prawidłowo. Proszę uzbroić się w cierpliwość - to nie potrwa długo :)
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661
[AUR]  [GitHub]

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Repozytorium Arch-Like
« Odpowiedź #12 dnia: Styczeń 12, 2015, 20:52:06 »
W tej chwili oba repozytoria kde* zostały wyłączone. Okazuje się, że paczki z KDE Applications (przynajmniej niektóre) budowane na systemie, na którym jest Plasma5, nawet te, które są oparte o KF5 i które powinny (oczywiście po doinstalowaniu zależności) działać w KDE4 poszukują w tym środowisku pewnych plików (najczęściej biblioteki) w innych miejscach niż są one umieszczone w KDE4. Z drugiej strony, paczki budowane w KDE4, które są budowane na KF5 nie działają (przynajmniej niektóre) w środowisku Plasma5.
W tej chwili nie mamy innego wytłumaczenia, jak to, że paczki - aby prawidłowo działały - muszą być zbudowane w tym środowisku, w którym mają potem pracować (niezależnie od tego, czy są to jeszcze paczki poprawkowe dla środowiska KDE4, czy też oparte już o KF5, ba dotyczy to także paczek, których zmianą jest wyłącznie zmiana "numerka" wersji). Dodatkowo, jeśli środowisko Plasma5 zostało wyposażone w jakieś dodatkowe aplikacje oparte o KF5, które są dostępne obecnie wyłącznie w git, to paczka zbudowana w takim środowisku nie będzie prawidłowo pracować w innym środowisku Plasma5, w której są zastosowane wyłącznie KDE Applications z oficjalnego wydania.
Tak, czy inaczej - wydaje się, że w środowisku KDE4 brakuje jakiejś paczki integrującej z nowymi aplikacjami wydawanymi w ramach KDE Applications.
Zobaczymy jak to będzie wyglądać w środę (jutro wszak ma się ukazać wydanie poprawkowe 14.12.1), może ono coś poprawi.
Zasadniczy problem leży też w pacmanie, który nawet jeśli zaproponowalibyśmy rozwiązanie typu paczka-kde4 i paczka-plasma5, to każda z nich winna dostarczać pacmanowi informacje, że jest "następcą" paczki z dotychczasowego KDE4. Sęk w tym, że obie one muszą mieć mieć taką samą informację i w tym momencie następuje konflikt, albowiem nie istnieje prosty sposób na zainstalowanie ich w systemie (tj. poinformowania pacmana, które paczki mają być aktualizowane na danym systemie).
Tak jak wspomniałem - zobaczymy co z tym fantem da się zrobić.
Jedno z możliwych rozwiązań do przyjęcia jest takie, by paczki były udostępniane w dwu oddzielnych repozytoriach, oddzielnie budowane dla Plasma5 i dla KDE4 i wówczas ktoś, kto ma dane środowisko, musi podłączyć repozytorium dla danego środowiska oraz dokonać pełnej aktualizacji systemu (zresztą taka jest w zasadzie wyłącznie dopuszczalna w Archu). Inne to w ogóle wyłączenie takich repozytoriów i pozostawienie wyłącznie PKGBUILDów umożliwiających budowę paczek we własnym zakresie. Pozostanie natomiast repozytorium archlike, w którym będą paczki niezależne od KDE.
Na nasze usprawiedliwienie można dodać, że podobne problemy nie uniknęły również TU Archa, którzy udostępnili swoje paczki (tu akurat kde-beta), albowiem po dołączeniu tego repozytorium w Plasma5 nie jest możliwe dokonanie tzw. pełnego upgrade'u ze względu na kłócące się paczki.
Jeśli macie inne pomysły, to dajcie znać. Być może w ogóle pomysł jest chybiony i nie należy wychodzić przed szereg i poczekać jak się sprawa rozwinie.

sir_lucjan

  • AUR-OR
  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 1327
  • Reputacja +11/-0
  • Nic nie działa, jak Polska cała!
    • Mój profil w AUR
  • Architektura: x86_64
  • DE/WM: Plasma 5
  • Distro: Arch Linux
  • GPU: Intel
  • Kernel: linux-bfq-haswell
Odp: Repozytorium Arch-Like
« Odpowiedź #13 dnia: Styczeń 13, 2015, 17:13:46 »
Dzisiaj ukazała się aktualizacja KDE Applications do wersji 14.12.1. Jednocześnie ukazała się nowa wersja środowiska KDE 4.14.4. Jeśli developerzy Arch nie umieszczą poprawek, postaram się wrzucić to  do repozytorium. Niemniej będą to wersje działające tylko i wyłącznie na KDE 4. Przewidywalna liczba paczek to:

[lucjan@archlinux ~]$ pacman -Sl kde4last | wc -l
171

Jeśli do piątku ważniejsze aplikacje z KDE 4.14.4 / 14.12.1 nie trafią do repo, postaram się umieścić nowe wersje na serwerze w poniedziałek.
« Ostatnia zmiana: Styczeń 13, 2015, 17:18:53 wysłana przez sir_lucjan »
Dell Inspiron 15-3542 (3542-2538) || Linux Register User: #536661
[AUR]  [GitHub]

 

Polityka cookies
Darmowe Fora | Darmowe Forum
rodzina volkoria pack-of-black-and-white jezyki2 pupek