Autor Wątek: Plasma 5 i błąd could not sync environment to dbus po aktualizacji dbus  (Przeczytany 1020 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Jeśli ktoś dokonał wczoraj (22.01) aktualizacji systemu, to m.in. zainstalowały mu się paczki dbus i libdbus w wersji 1.8.14-1, co - w systemie korzystającym z Plasma5 - prawdopodobnie wywołało błąd wyświetlający:
could not sync environment to dbus
Błąd pojawia się w systemach, które mają łącznie zainstalowane dbus i libdbus w wersji 1.8.14-1 i plasma-worskpace w wersji co najwyżej 5.1.2-3. Dzisiaj dostępna jest już wersja 5.1.2-4 plasma-workspace, zawierająca odpowiedni patch.

Istnieją dwa wyjścia z tej sytuacji:
- pierwsze, zalecane, to aktualizacja plasma-workspace do wersji 5.1.2-4,
- drugie, to wstępne cofnięcie paczek dbus i libdbus do wersji 1.8.12-1 (poprzedniej), a następnie dokonanie aktualizacji.

Błąd mnie ominął, bowiem nie mam już Plasma 5.1 (mam środowisko z git, czyli odpowiadające Plasma 5.2), zatem nie wiem, w którym miejscu  się pojawia - zakładam, że związany jest ze startem środowiska. Możliwa naprawa systemu może się zatem odbyć w następujące sposoby:
- jeśli ktoś ma inne środowisko lub przynajmniej jakiś WM - zalogowanie się do niego i dokonanie naprawy w sposób opisany wyżej, lub
- jeśli ktoś ma uruchomioną pozycję recovery w GRUB (zob.: http://www.archlike.darmowefora.pl/index.php/topic,60.0.html) dokonanie jej wyboru i albo połączenie się z siecią (prawdopodobnie będziecie musieli podnieść usługę NetworkManager), a następnie aktualizacja systemu, lub - jeśli macie dbus i libdbus w poprzedniej wersji w /var/cache/pacman/pkg/ - dezaktualiazja tych paczek przy zastosowaniu pacman -U,
- jeśli nie macie możliwości skorzystania z żadnej z powyższych opcji - schrootowanie systemu (zob.: http://www.archlike.darmowefora.pl/index.php/topic,93.0.html) i wykonanie działań opisanych powyżej.
Zalecam wpierw dokonanie aktualizacji obejmującej plasma-workspace w wersji 5.1.2-4

 

Polityka cookies
Darmowe Fora | Darmowe Forum
jezyki2 halotupsy rootsunderground volkoria wojownicyburzy