Autor Wątek: KDE Applications 14.12 (i późniejsze) w KDE4  (Przeczytany 727 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
KDE Applications 14.12 (i późniejsze) w KDE4
« dnia: Styczeń 23, 2015, 12:56:49 »
Jak już pewnie wiecie, dni środowiska KDE4 są już raczej policzone. Może nie dni, a miesiące. W każdym bądź razie raczej nie należałoby się spodziewać, że najpóźniej w okolicach wydania KDE Applications 15.10 to środowisko dalej będzie utrzymywane (chyba, że znajdą się osoby, które sforkują je podobnie jak to uczyniono z KDE 3.5). Obecna sytuacja wygląda w następująco:
1. Na bieżąco rozwijane jest środowisko, które zastąpić ma KDE4, a na które składają się:
- biblioteki (i nie tylko, generalnie współdzielone elementy środowiska), które znajdziemy w grupach kf5 oraz kf5-aids, a które odpowiadają KDE Frameworks; te elementy mogą koegzystować w jednym systemie obok dotychczasowego KDE4,
- "samo" środowisko, czyli Plasma 5, które znajdziemy w grupie plasma-next i te elementy nie mogą występować łącznie z KDE4 (chodzi o jego Plasmę, czyli kdebase-workspace i biblioteki z nią związane).
2. Niezależnie od środowiska, aplikacje, które dawniej były dostarczane w ramach "pełnego" KDE4, są rozwijane jako KDE Applications. Co cztery miesiące, począwszy od grudnia 2014 będzie dostarczany nowy ich zbiór. W jego skład wchodzą aplikacje, które są zbudowane zarówno w oparciu o KF5 (czyli są zbudowane także w oparciu o framework Qt5), jak i w oparciu o dawne komponenty KDE4 (i które zbudowane są na Qt4). W ramach tego zbioru, aplikacje, które zostają przeportowane do KF5/Qt5 są porzucane w dotychczasowej wersji opartej o KDE4/Qt4. Dla przykładu, wraz z KDE Applications 14.12 pojawiły się np. Kate, Konsole, czy Gwenview w wersjach zbudowanych na  Qt5 i korzystające z bibliotek KF5. Jednocześnie te aplikacje w wersji opartej o Qt4 i korzystające z bibliotek KDE4 przestały być rozwijane wraz z wydaniem 4.14.3.
3. Dwa elementy KDE4 uzyskały przedłużone wsparcie. Dotyczy to samej Plazmy, czyli kdebase-workspace oraz aplikacji składających się na zbiór KDEPIM (Kontact). Będą one rozwijane w zasadzie tak długo, aż nie zostanie przeportowana ostatnia z zamierzonych do portowania aplikacji dostarczanych wraz z KDE4. W zasadzie można powiedzieć, że taką aplikacją może być albo KDEPIM właśnie, albo Calligra. Po tym okresie nastąpi porzucenie środowiska KDE4. W zasadzie za ostateczną datę uznać można koniec obecnego roku, albowiem tylko do końca roku wsparcie uzyskało Qt w wersji 4 (i tak zostało ono przedłużone o rok).

Nie jest konieczne, przynajmniej do czasu porzucenia Plazmy w wersji KDE4 przenoszenie się na nowe środowisko Plasma5, jednakże trzeba pamiętać o kilku rzeczach.
Jeśli - co jest raczej prawdopodobne - nie znajdą się osoby, które będą chciały rozwijać porzucone KDE4 (oraz również porzucone Qt4 - a razem jest to kawał roboty), to najpóźniej wraz z zaprzestaniem wsparcia Plasmy w wersji dostarczanej wraz z kdebase-workspace należy się przenieść na nowe środowisko lub wybrać inne. Pamiętajmy, że brak wsparcia dotyczy wszystkich aspektów środowiska, czyli nie tylko jego funkcjonalności, ale przede wszystkim bezpieczeństwa.
Nowe aplikacje, oparte o KF5 mogą się źle integrować z KDE4. Wprawdzie jeszcze w wersji Plasma 5.1 winny one posiadać możliwość używania dekoracji Oxygen, jednakże już w Plasma 5.2 próżno go szukać w formie, która była nam znana. Nie wiem, czy jest to wypadek przy pracy i Oxygen (dekoracje okien) powrócą w późniejszym cyklu wydawniczym, czy też nie. Efekt jest taki, że aplikacje te już niebawem nie będą mogły korzystać z Oxygena i będą się różnić od aplikacji KDE4. Takich aplikacji, co cztery miesiące będzie coraz więcej. Już dzisiaj mogę powiedzieć, że zaawansowanie przeportowania aplikacji składających się na kdebase (czyli m.in. Dolphin) jest bardzo duże i raczej należy spodziewać się, że przynajmniej one zostaną wprowadzone wraz z wydaniem KDE Applications 15.04. Także część innych winno zostać przeportowanych do tego czasu (np. Ark, bo już są one stabilne). Stopień zaawansowania portowania KDEPIM raczej też jest duży i nie sądzę, by ich wersja oparta o KF5 pojawiła się później niż wraz z KDE Applications 15.08. Jak widzicie, będziecie musieli albo pogodzić się z odmiennym wyglądem aplikacji zbudowanych dla KDE4 oraz dla Plasmy5, albo zdecydować się na zmianę wyglądu środowiska (być może breeze-kde4 przyniosłoby pożądany efekt, ale trzeba pamiętać o tym, że jak dotychczas nie ma tego motywu dla aplikacji opartych o Gtk, można jednak próbować, ze zbliżonym tematem o nazwie Menda od Manjaro), albo poszukać zamienników, albo... przejść na Plasmę5 wcześniej.
W Plasma5 aplikacje KDE4 dość dobrze ujednolicają swój wygląd z nowym środowiskiem. Gorzej z niektórymi aplikacjami opartymi o "czyste" Qt4 (np. odtwarzacz ROSA Media Player), które nie bardzo się chcą ujednolicić. Nie ma jednak róży bez kolców. Jeśli korzystacie np. z Calligry czy (co gorsza) Tellico, to nie istnieje możliwość ich instalacji w środowisku Plasmy 5, albowiem jej zależnościami jest kdebase-workspace (a w zasadzie są po prostu oparte o te biblioteki, choć prawdę mówiąc, są to jeszcze naleciałości bibliotek Qt3, które wspierane przez KDE4 jeszcze były, a przez Plasmę 5 już nie są). Nie uruchomicie tutaj też żadnej aplikacji napisanej w oparciu o Qt3. Calligra w najbliższym czasie (tj w okolicach kwietnia) winna się pozbyć ostatnich bibliotek z qt3, z których jeszcze korzysta, co winno jej umożliwić otwieranie się w środowiskach opartych o Qt5 (oprócz Plasma5, to również LXQT czy Hawaii, ale także... Unity 8). Wydanie to będzie jednak w zasadzie przejściowe, bowiem od razu rozpoczęte zostaną prace nad przeportowaniem jej do Qt5/KF5. Obecnie już Krita została przeportowana do Qt5. Niestety nie wiem jak z Tellico. Nie ma natomiast problemu z takimi aplikacjami jak Amarok, czy Clementine, albowiem te (przynajmniej pierwsza z nich) oparte o Qt4 bez problemu uruchamiają się w Plasma5.
« Ostatnia zmiana: Styczeń 23, 2015, 16:04:07 wysłana przez pavbaranov »

 

Polityka cookies
Darmowe Fora | Darmowe Forum
rootsunderground pupek filtrowa36 volkoria wataha-mocy