Autor Wątek: Aplet pogody dla Plasma 5  (Przeczytany 1643 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Aplet pogody dla Plasma 5
« dnia: Styczeń 31, 2015, 13:03:01 »
Niestety, wraz z nastaniem Plasma 5 większości plasmoidów, przygotowanych dla KDE4 nie można używać (albo funkcjonalność jest delikatnie mówiąc cząstkowa, albo zależności od bibliotek KDE4, albo jeszcze coś innego). W ten sposób wypadły z tego systemu wszystkie aplety pogodowe, takie jak choćby CWP. Także systemowego apletu również nie ma. Jedyny, jaki znalazłem, to meteo-qt, który został już dostosowany do Qt5 i może być stosowany w Plasmie 5.
Instalacja:
Mamy do wyboru dwie opcje, albo zainstalowanie stabilnej wersji, albo wersji git. Ta druga jest równie stabilna co wersja "stabilna", a z uwagi na ciągły rozwój apletu, szybciej można się spodziewać jakichś nowości i usprawnień. Niestety, meteo-qt oferuje tylko jednego dostawcę pogody (bodaj Yahoo). Oba aplety instalujemy z AUR:
a. Wersja stabilna:
yaourt -S meteo-qtb. Wersja git:
yaourt -S meteo-qt-gitAby aplet był widoczny od razu, koniecznym jest jeszcze uruchomienie skryptu w systemsettings:
Ustawienia systemowe -> Uruchamianie i wyłączanie -> Samoczynne uruchamianie -> Dodaj program
i dodajemy meteo-qt.
Potem trzeba aplet skonfigurować, jednakże jest to tak proste, że pominę.

 

Polityka cookies
Darmowe Fora | Darmowe Forum
jezyki2 filtrowa36 pack-of-black-and-white wojownicyburzy rootsunderground