Autor Wątek: Nieco porządku z KDE - terminarz wydań  (Przeczytany 1887 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Nieco porządku z KDE - terminarz wydań
« dnia: Marzec 27, 2015, 13:29:07 »
W przeciwieństwie do starych dobrych czasów, "nowe" KDE wydawane jest w trzech niezależnych częściach: Frameworks, Plasma i Applications, w dodatku w różnych terminach. Postarałem się zestawić nadchodzące wydania nieco inaczej niż KDE Schedule. Repozytoria są "archowe".
2015.
Listopad:
10.11 - Plasma 5.4.3
10.11 - KDE Applications 15.08.3
14.11 - KF 5.16
18.11 - KDE Applications 15.11.80 (aka 15.12 beta)
19.11 - Plasma 5.4.95 (aka 5.5 beta)
Grudzień:
2.12 - KDE Applications 15.11.90 (aka 15.12 RC)
8.12 - Plasma 5.5.0
12.12 - KF 5.17
15.12 - Plasma 5.5.1
16.12 - KDE Applications 15.12
22.12 - Plasma 5.5.2
2016:
Styczeń:
5.01 - Plasma 5.5.3
12.01 - KDE Applications 15.12.1
26.01 - Plasma 5.5.4
Luty:
16.02 - KDE Applications 15.12.2
Marzec:
1.03 - Plasma 5.5.5
15.03 - KDE Applications 15.12.3

EDIT 26.09.2015
Uprościłem ten kalendarz poprzez usunięcie archiwalnych wydań.

Z końcem sierpnia zakończone zostało wsparcie dla kdebase-workspace, do końca grudnia 2015 wsparcie ma jeszcze Qt4. Wersja KDE Applications 15.12 winna już zawierać przeportowane wszystkie aplikacje, które weń wejdą (bo chyba nie będą to wszystkie dawne aplikacje KDE) do KF5/Qt5. Również do końca roku winny ukazać się Digikam oparty o KF5 (obecnie Beta) i Calligra przygotowana na KF5 (obecnie Alpha).
Spodziewane zakończenie portowania aplikacji KDE do Qt5/KF5 nie oznacza, że wszystkie Wasze ulubione aplikacje oparte o Qt, czy też (a może nawet tym bardziej) Plasmoidy, do których przyzwyczailiście się na KDE4 zostaną przeportowane. W tym drugim przypadku część spośród nich została włączona w Plasmę, część uzyskała swoich zastępców. Duża część jednak pozostanie w mrokach dziejów. O ile nie ma problemu z korzystaniem z aplikacji Qt4 w środowiskach Qt5 (w przeciwieństwie do aplikacji Qt3 - z tych nie skorzystamy), to plasmoidy muszą być oparte o QML (bodaj 2) by mogły być wykorzystywane w Plasmie. Wszystkie inne nie nadają się do wykorzystania.
« Ostatnia zmiana: Listopad 07, 2015, 09:47:24 wysłana przez pavbaranov »

 

Polityka cookies
Darmowe Fora | Darmowe Forum
telenovelas kurwistan naszewatahy funnybunny ptasiekamerki