Autor Wątek: Kscreengenie-git  (Przeczytany 1772 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Kscreengenie-git
« dnia: Kwiecień 20, 2015, 13:09:17 »
Kscreengenie jest aplikacją, która ma zastąpić KSnapshot w Plasma5/KF5 (zob: http://quickgit.kde.org/?p=kscreengenie.git).
PKGBUILD
# Maintainer: Antonio Rojas

pkgname=kscreengenie-git
pkgver=r23.5548b4b
pkgrel=1
pkgdesc='Screen Capture Program'
arch=('i686' 'x86_64')
url='http://kde.org/applications/graphics/ksnapshot/'
license=('GPL')
depends=('kcoreaddons' 'kdeclarative' 'kconfig' 'ki18n' 'kio' 'kxmlgui' 'kwidgetsaddons' 'kwindowsystem' 'libkipi-frameworks-git' 'kscreen')
makedepends=('extra-cmake-modules' 'git' 'kdoctools' 'pkg-config')
conflicts=('kdegraphics-ksnapshot' 'ksnapshot')
replaces=('ksnapshot-frameworks-git')
provides=('ksnapshot')
source=("git://anongit.kde.org/kscreengenie.git")
install=$pkgname.install
sha256sums=('SKIP')

pkgver() {
  cd kscreengenie
  printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

prepare() {
  mkdir -p build
}

build() {
  cd build
  cmake ../kscreengenie \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_BUILD_TYPE=Release \
    -DLIB_INSTALL_DIR=lib \
    -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
  make
}

package() {
  cd build
  make DESTDIR="$pkgdir" install
}
kscreengenie-git.install
post_install() {
    xdg-icon-resource forceupdate --theme hicolor &> /dev/null
    update-desktop-database -q
}

post_upgrade() {
    post_install
}

post_remove() {
    post_install
}
Do działania, wymaga libkipi-frameworks-git, które najłatwiej zainstalować z archlinuxcn dodając do /etc/pacman.conf wpis:
[archlinuxcn]
SigLevel = Optional TrustAll
Server = http://repo.archlinuxcn.org/$arch
Jest też możliwość zbudowania tej paczki z AUR (wówczas musimy ją zbudować przed zbudowaniem kscreengenie).
Uwaga: libkipi-frameworks-git konfliktuje z libkipi (czyli w procesie instalacji ten ostatni pakiet zostanie zastąpiony), który jest oparty o biblioteki KDE4. Jeśli zatem ktoś ma w systemie jakąś aplikację, która wykorzystuje libkipi (bodaj najpopularniejszą jest Digikam) to wówczas nie polecam instalacji kscreengenie, albowiem utracicie możliwość korzystania z takiej aplikacji (chyba, że również ją zbudujecie w wersji opartej o KF5; w przypadku digikama daje się to zrobić).
« Ostatnia zmiana: Kwiecień 20, 2015, 23:01:41 wysłana przez pavbaranov »

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Odp: Kscreengenie-git
« Odpowiedź #1 dnia: Sierpień 19, 2015, 10:51:25 »
Skrypty zostają porzucone, ze względu na to, że wersja stabilna znajduje się obecnie w community, a wersja -git w AUR.

 

Polityka cookies
Darmowe Fora | Darmowe Forum
jezyki2 wojownicyburzy filtrowa36 pupek halotupsy