Autor Wątek: AUR4 i aktualizacje  (Przeczytany 1334 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
AUR4 i aktualizacje
« dnia: Czerwiec 16, 2015, 08:41:35 »
Jak już wiecie, od tygodnia nowe skrypty budujące paczki w AUR winny być umieszczane w aur4.archlinux.org. I są. Niestety popularne narzędzia do obsługi AUR nie potrafią jeszcze korzystać z AUR4. Powoduje to, że w przypadku przeniesienia skryptu do AUR4, wydanie komendy aktualizującej aplikacje z uwzględnieniem AUR nie zostaną zauważone jakiekolwiek zmiany wersji i system, w części dostarczanej przez AUR, nie zaktualizuje się. Istnieje łatwy sposób zmuszenia yaourta, by "widział" paczki na AUR4 (potrzeba potem wydania 2 komend, by ogarnął całość), ale nie potrafi niczego z AUR4 ściągnąć ani zainstalować.
Przystosowanie yaourt do widzenia paczek z AUR4 to wydanie komendy:
yaourt --aur-url https://aur4.archlinux.org <nazwa_operacji><nazwa_paczki>Dla ułatwienia można sobie zrobić alias.
Paczek tych nie zobaczą jednak np. pkgbrowser, pamac czy octopi.
Budowa, instalacja i aktualizacja paczek dostępnych w AUR możliwa jest obecnie wyłącznie "tradycyjnym" sposobem, opisanym w wiki Archa. Można być natomiast nieco skonfudowanym, ze względu na panujący tymczasowo nieporządek. Część skryptów jest w AUR4, skrypty do których się odwołują, niekiedy są w AUR4, niekiedy w AUR - innymi słowy trzeba przeglądać oba.

Przykład różnic:
yaourt linux-lqx
(...)
3 aur/linux-lqx 4.0.4-2
(...)
oraz:
yaourt4 linux-lqx
1 aur/linux-lqx 4.0.5-2
(...)
Pierwsze polecenie przeszukuje AUR, drugie - z wykorzystaniem podanego wyżej sposobu - wykorzystuje AUR4. Niemniej jednak wydanie polecenia:
yaourt -S linux-lqxzainstaluje wersję 4.0.4-2, a polecenia:
yaourt4 -S linux-lqx sypnie błędem:
yaourt4 -S linux-lqx

==> Pobieranie PKGBUILD linux-lqx z AUR...
==> BŁĄD:linux-lqx nie został znaleziony w AUR.
Tę ostatni komunikat należy interpretować w ten sposób, że yaourt nie potrafi wykonać operacji, a nie, że jest ona niemożliwa. Na stronie aur4.archlinux.org stosowny skrypt dla linux-lqx jest.

Obecna sytuacja, tj. dualizmu obu AURów będzie istnieć do 8.08.2015 r., przy czym 8.07.2015 r. jest jeszcze jedna cezura. O ile do lipca właśnie opiekunowie paczek w dotychczasowym AUR mogą dokonywać ich aktualizacji (czyli np. yaourt, jeśli pojawi się coś nowego w obecnym AUR będzie w stanie to zaktualizować), to później, jakiekolwiek nowe skrypty, czy aktualizacje istniejących będą wykonywane już na AUR4, z którego yaourt (i inne) niczego nie aktualizuje (przynajmniej na razie). Po 8.08.2015 r., obecny AUR4 stanie się AUR (tzn. otrzyma tę samą domenę).
Można liczyć, że do początku lipca zaczną się pojawiać wrappery pacmana obsługujące AUR4. Jeśli tak się nie stanie, to w drugim tygodniu lipca podam jak zmienić yaourtrc by służył przynajmniej jako funkcjonalny informator o pojawieniu się nowych wersji w AUR4. Dalsza instalacja będzie musiała już przebiegać ręcznie.
« Ostatnia zmiana: Czerwiec 16, 2015, 10:44:54 wysłana przez pavbaranov »

 

Polityka cookies
Darmowe Fora | Darmowe Forum
kurwistan k-l klasa4a nielegalnewyscigi naszewatahy