Autor Wątek: Dolphin KF5 dla KF5.13  (Przeczytany 1075 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

pavbaranov

  • Administrator
  • Ekspert
  • *****
  • Wiadomości: 848
  • Reputacja +25/-0
  • Architektura: x86_64
  • DE/WM: KF5.16+Plasma5.4.95+KDEApps 15.11.80+git na KF5
  • Distro: Arch Linux
  • GPU: Radeon free
  • Kernel: 4.3 (BFQ/CK/BLD/UKSM/+optymalizacje)
Dolphin KF5 dla KF5.13
« dnia: Sierpień 13, 2015, 17:20:01 »
Wraz z nowym KF5.13 nie bardzo radzi sobie Dolphin (KF5) w wersji 15.07.80 lub nawet git.
Poniżej skrypty, które umożliwiają zbudowanie Dolphina w wersji 15.07.90 na podstawie KF5.13. Budujemy najpierw paczki kio-extras i baloo-widgets, dopiero potem dolphin.

[eng]
Dolphin 15.07.90 works and builds against of KF5.13. You have to build all packages in this order: kio-extras, baloo-widgets, dolphin. It should works. Every comments are welcome.

1. KIO-EXTRAS:
PKGBUILD
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Antonio Rojas
# Contributor for ver. 15.07.90: pavbaranov (pb)

pkgname=kio-extras
pkgver=15.07.90
pkgrel=1
pkgdesc="Additional components to increase the functionality of KIO"
arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/kde/workspace/kio-extras'
license=('LGPL')
depends=('kdelibs4support' 'khtml' 'kdnssd' 'libssh' 'smbclient'
         'exiv2' 'openexr' 'openslp' 'libmtp' 'kpty')
makedepends=('extra-cmake-modules' 'kdoctools' 'python')
groups=('plasma')
install="${pkgname}.install"
source=("http://download.kde.org/unstable/applications/${pkgver}/src/$pkgname-$pkgver.tar.xz")
md5sums=('2e2930820d26a064c4dcd54cdbea3d2a')

prepare() {
  mkdir build
}

build() {
  cd build
  cmake ../${pkgname}-${pkgver} \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DLIB_INSTALL_DIR=lib \
    -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
    -DBUILD_TESTING=OFF
  make
}

package() {
  cd build
  make DESTDIR="${pkgdir}" install
}
kio-extras.install
post_install() {
    update-mime-database usr/share/mime &> /dev/null
}

post_upgrade() {
    post_install
}

post_remove() {
    post_install
}

2. BALOO-WIDGETS
PKGBUILD
# Contributor: Andrea Scarpino <andrea@archlinux.org>
Contributor for ver. 15.07.90: pavbaranov (pb)

pkgname=baloo-widgets
pkgver=15.07.90
pkgrel=1
pkgdesc="A framework for searching and managing metadata"
arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/kde/kdelibs/baloo'
license=('LGPL')
depends=('baloo')
makedepends=('extra-cmake-modules' 'git' 'kdoctools')
source=('http://download.kde.org/unstable/applications/15.07.90/src/baloo-widgets-15.07.90.tar.xz')
conflicts=('baloo-widgets-git')
replaces=('baloo-widgets-frameworks-git' 'baloo-widgets-git')
md5sums=('31903e43027794575043f3728d9f69d7')

#pkgver() {
#  cd baloo-widgets
#  printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
#}

prepare() {
  mkdir -p build
}

build() {
  cd build
  cmake ../baloo-widgets-$pkgver \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DLIB_INSTALL_DIR=lib
  make
}

package() {
  cd build
  make DESTDIR="$pkgdir" install
}

3. DOLPHIN
PKGBUILD
# Maintainer: Antonio Rojas <arojas@archlinux,org>
Contributor for ver. 15.07.90: pavbaranov (pb)

pkgname=dolphin
pkgver=15.07.90
pkgrel=1
pkgdesc="File Manager"
arch=(i686 x86_64)
url="http://kde.org/applications/system/dolphin/"
license=(LGPL)
depends=(baloo-widgets knewstuff kio plasma-workspace ktexteditor kactivities-frameworks kio-extras)
makedepends=(extra-cmake-modules kdoctools python)
provides=(dolphin)
conflicts=(dolphin-git dolphin kdebase-dolphin dolphin-frameworks-git)
replaces=(dolphin-frameworks-git)
source=('http://download.kde.org/unstable/applications/15.07.90/src/dolphin-15.07.90.tar.xz')
install=$pkgname.install
md5sums=('5a05b3fa09aec381e5a65ce0f037cc32')

prepare() {
  mkdir -p build
}

build() {
  cd build
  cmake ../dolphin-$pkgver \
    -DCMAKE_BUILD_TYPE=Release \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DLIB_INSTALL_DIR=lib \
    -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
    -DBUILD_TESTING=OFF
  make
}

package() {
  cd build
  make DESTDIR="$pkgdir" install
}
dolphin.install
post_install() {
    xdg-icon-resource forceupdate --theme hicolor &> /dev/null
    update-desktop-database -q
}

post_upgrade() {
    post_install
}

post_remove() {
    post_install
}

EDIT:
Cóż wpis powstał na prośbę kilku uczestników BBS Archa i dzisiaj okazuje się już niepotrzebny. W repozytorium [kde-unstable] są te same paczki. Pamiętajmy o konieczności uruchomienia repozytorium [testing] jeśli chcemy z niego korzystać.

[eng]
Since  today it's not neccessary to build those packages because of  all of them are in kde-unstable repos in Arch.
« Ostatnia zmiana: Sierpień 14, 2015, 12:21:01 wysłana przez pavbaranov »

 

Polityka cookies
Darmowe Fora | Darmowe Forum
telenovelas funnybunny klasa4a nielegalnewyscigi planetside2grompl